スポンサーサイト 

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Firefoxのバージョンに対応していないアドオンを無理矢理使えるようにする 

自分用メモです
以下は自己責任でお願いいたします

Firefoxがバージョンアップしたときに
Add-onが対応していないとき使用不可になっちゃうわけですよ

それで正式な対応バージョンが出るのを待てないときはどうしたら良いか?
1. おとなしく待つ

2. extensions.checkCompatibilityを設定してバージョンチェックを無効にする
  → Firefox3.6から仕様が変わったらしく、"extensions.checkCompatibility.3.6"って言うキーになったらしい

3. Add-onの設定ファイルを書き換えて無理矢理バージョンに対応していることにする

で、3.の方法をメモっておきます



1. ?.xpiをダウンロードする
2. 解凍する
3. install.rdfってファイルをメモ帳で開く
4. <em:targetApplication>タグの中にある
  <em:maxVersion>を探して、書き換える
  例)
<em:maxVersion>3.5.*</em:maxVersion>
     ↓
<em:maxVersion>3.6.*</em:maxVersion>
5. ZIPで固める
6. 拡張子をZIPからxpiに変更する
7. Firefoxにファイルをドロップしてインストール

動けばラッキー
動かなければ残念。正式対応を待ちましょう

スポンサーサイト

コメント

コメントの投稿















管理者にだけ表示を許可する

トラックバック

この記事のトラックバックURL
http://higuti.blog8.fc2.com/tb.php/1285-e4afb4fa
Mozilla Firefox ブラウザ無料ダウンロード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。